Authentication issues with RM SafetyNet Go

Incident Report for RM Internet & E-safety

Resolved

The issues experienced yesterday with SafetyNet Go have now been resolved. However, if you continue to experience any issues, please contact our Service Desk using your normal support routes.
Posted Aug 28, 2025 - 10:13 BST

Investigating

We are currently investigating an issue with a subset of users authenticating with RM SafetyNet Go. We will provide further updates as soon as possible.
Posted Aug 27, 2025 - 12:25 BST
This incident affected: Web Filtering (SafetyNet Plus).