Browsing issues in Surrey
Incident Report for RM Internet & E-safety
Resolved
We have identified and fixed the root cause of this incident. Affected customers have confirmed services are now working as expected.
Posted 4 months ago. Jul 12, 2017 - 09:26 BST
Investigating
We are aware of an issue affecting internet browsing for a small number of customers in Surrey who do not use RM SafetyNet. We are investigating this as a priority.
Posted 4 months ago. Jul 12, 2017 - 09:02 BST
This incident affected: SEGfL Connectivity.