Performance issue affecting Safetynet browsing for the Youtube/ChatGPT for the SWGFL customers

Incident Report for RM Internet & E-safety

Resolved

We have confirmed that the issue identified with SafetyNet Filtering for SWGFL customers has now been resolved.

If you continue to experience further issues, please log these via your normal support channels.
Posted Sep 10, 2025 - 10:31 BST

Update

Browsing performance is restored. We will continue to monitor the service.
Posted Sep 08, 2025 - 12:00 BST

Investigating

We are aware of a degraded performance issue for SWGFL customers. Our engineers are currently investigating and will provide a further update shortly.
Posted Sep 08, 2025 - 11:19 BST
This incident affected: Web Filtering (SafetyNet Plus).