Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 28, 2025 - 00:00 BST
Scheduled
We will be performing planned maintenance on some end-customer leased line circuits between Monday 28th July and Thursday 29th August 2025.
During this period, there may be brief service interruptions, with an at risk window of up to 2 hour per circuit. This work is part of our ongoing efforts to ensure the continued performance, reliability, and security of our network.
Maintenance will be scheduled outside of core hours wherever possible to minimise disruption. No end-customer circuits will be affected during exam results windows.
We appreciate your understanding as we carry out this essential work. Any updates or changes will be posted here. For any questions or concerns, please contact your support team.
Posted Jul 22, 2025 - 09:24 BST
This scheduled maintenance affects: RM Connectivity.