Issue affecting DNS platform

Incident Report for RM Internet & E-safety

Resolved

We have identified the root cause of customers being unable to make DNS changes. This has been rectified and confirmed as working. Should you continue to encounter issues with changing DNS records, please log this via your normal support channels.
Posted May 08, 2026 - 10:34 BST

Investigating

We are aware of an issue preventing customers from making changes to their DNS records. We are currently investigating and will provide an update as soon as one is available
Posted Apr 20, 2026 - 13:26 BST
This incident affected: DNS.