Issues with SafetyNet Browsing This Morning

Incident Report for RM Internet & E-safety

Resolved

This issue is now resolved.
Posted Oct 08, 2025 - 11:03 BST

Update

We have continued to monitor performance of SafetyNet throughout the week and will continue to do so throughout the start of the coming week. Should you experience any issues, please continue to log these through your usual support channels.
Posted Sep 19, 2025 - 14:29 BST

Monitoring

We have identified the root cause and have now resolved the issue. Should you continue to encounter issues, please log these via your normal support channels. We will continue to monitor performance throughout the day.
Posted Sep 15, 2025 - 08:51 BST

Investigating

We are aware of an issue affecting users browsing the internet using SafetyNet this morning. We are currently investigating and will provide further updates when available.
Posted Sep 15, 2025 - 08:27 BST
This incident affected: Web Filtering (SafetyNet Plus).