The issues experienced with SafetyNet Go have now been resolved. We will continue to monitor the services. However, if you continue to experience any issues, please contact our Service Desk using your normal support routes.
Posted Oct 23, 2025 - 11:08 BST
Monitoring
The earlier performance issue causing web pages to fully or partially fail to load has been resolved now. Some customers may still experience an issue with blank sections on web pages when a browser has been left idle for a short time, refreshing the page before continuing with browsing will prevent this issue from occurring, and will reload the page fully if this symptom is seen. We are continuing to monitor the situation carefully and will update again once this secondary issue has also been resolved.
Posted Oct 21, 2025 - 15:53 BST
Update
We believe we have identified the root cause of the issues and are working to remediate currently.
Posted Oct 21, 2025 - 13:37 BST
Update
We are continuing to investigate the issue and will provide further updates as we have them.
Posted Oct 21, 2025 - 11:21 BST
Investigating
We are aware of an issue affecting users of SafetyNetGo. We are currently investigating and will provide further updates when available.
Posted Oct 21, 2025 - 10:15 BST
This incident affected: Web Filtering (SafetyNet Plus).