Degraded Service for a subset of RM Broadband Customers
Incident Report for RM Internet & E-safety
Resolved
We have monitored the performance of the service and confirm that it is now stable with no further attacks.
Posted Apr 24, 2024 - 11:58 BST
Monitoring
We have identified a denial of service attack targeted at one of our customers. We have put mitigation in place to block the attack and are seeing no further impact. We will continue to monitor the service for any further attacks.
Posted Apr 23, 2024 - 14:40 BST
Investigating
We are aware of an issue affecting a subset of RM Broadband customers.

We are currently investigating the cause and will provide an update as soon as we know more.
Posted Apr 23, 2024 - 13:35 BST
This incident affected: RM Connectivity.