Internet browsing issue for FTTP/FTTC customers
Incident Report for RM Internet & E-safety
Resolved
We have monitored the service and confirmed that there has been no further performance degradation. Our telecommunication partner have confirmed the issue has been resolved within their network.
Posted Apr 19, 2024 - 10:06 BST
Monitoring
Our Telecommunication partner have confirmed that they have identified the root cause and the issue has been resolved. It appears that the service is now stable, and we will continue the monitoring.
Posted Apr 18, 2024 - 14:22 BST
Investigating
We are aware of an internet browsing issue affecting a small number of customers using FTTP connections. We are coordinating with our Telecommunication partner to fix the issue.
Posted Apr 18, 2024 - 13:07 BST
This incident affected: RM Connectivity.