Issues with SafetyNet Captive Portal

Incident Report for RM Internet & E-safety

Resolved

The earlier performance issue with the SafetyNet Captive Portal has been resolved.
If you are still having issues please raise this through the normal channels.
Posted Nov 06, 2025 - 11:43 GMT

Monitoring

The earlier performance issue with the SafetyNet Captive Portal we believe has now been resolved.
We are continuing to monitor the situation carefully however if you are still having issues please raise this through the normal channels.
Posted Oct 30, 2025 - 12:38 GMT

Update

We are continuing investigations with ongoing issues with the SafetyNet Captive Portal. We will provide further updates in due course.
Posted Oct 23, 2025 - 11:09 BST

Update

We are still investigating ongoing issues with the SafetyNet Captive Portal. We will provide further updates in due course.
Posted Oct 21, 2025 - 10:15 BST

Investigating

We are aware of an issue affecting users of the SafetyNet Captive Portal. We are currently investigating and will provide further updates when available.
Posted Oct 17, 2025 - 16:51 BST
This incident affected: Web Filtering (SafetyNet Plus).