Slow internet speed

Incident Report for RM Internet & E-safety

Resolved

This incident is now resolved.
We identified an issue on our network that is now fixed. Measures are also in place to prevent a repeat of this incident.
Posted Dec 19, 2014 - 10:29 GMT

Update

This incident only appears to be affecting customers on Talk Talk connections. We are working with Talk Talk to identify the root cause.
Posted Dec 19, 2014 - 09:53 GMT

Investigating

We are aware of an incident that is causing slow internet speeds for many users. Engineers are investigating this now. Further updates will follow.
Posted Dec 19, 2014 - 09:24 GMT
This incident affected: RM Connectivity.