Easymail mail service affected
Incident Report for RM Internet & E-safety
Resolved
The issue has been confirmed as resolved and service has returned to normal.
Posted 4 months ago. Apr 20, 2017 - 09:23 BST
Monitoring
The Easymail mail store issue has been resolved. Our Engineers will closely monitor the servers until the Root Cause Analysis is complete.
Posted 4 months ago. Apr 20, 2017 - 05:53 BST
Investigating
We are aware of an issue with Easymail service. Our engineers are actively working to resolve the issue.
Posted 4 months ago. Apr 20, 2017 - 04:51 BST
This incident affected: Email (Easymail).