Google Captcha Issues
Incident Report for RM Internet & E-safety
Resolved
There are no further issues related to Google Captcha are reported from the customers and our monitoring system also didn't detect any alerts for the same. As such we are closing this incident.
Posted Feb 04, 2022 - 11:31 GMT
Monitoring
No further issues reported from customers for more than a month. We dont see alerts in our monitoring system as well. We will continue to monitor the status & will proceed with investigation, if the issue reappears. Further updates will follow
Posted Jan 12, 2022 - 11:31 GMT
Update
We have implemented some advanced level monitoring tools to identify the schools which we believe generating suspicious traffics. Once we identified the schools which are generating malicious traffic, we will contact them and take the necessary actions to stop their further traffic through our network.

Our team is actively working towards a resolution and will keep you updated regarding the progress of the investigation.
Posted Dec 17, 2021 - 10:49 GMT
Update
We are still progressing with the investigation. Implemented some action plans as a part of our further investigation and also coordinating with Google to work out a permanenct resolution
Posted Nov 26, 2021 - 08:57 GMT
Update
The investigation is still in progress to find out the root cause and we will apply some action plans soon to test and resolve the issue. We will provide a further updates as soon as we have more information.
Posted Oct 27, 2021 - 14:09 BST
Investigating
We are aware that a number of customers have experienced an issue where they are presented with the Google Captcha (prove you are not a robot page). This issue is not caused by SafetyNet or the connection you have from us, however linked to a security feature of Google.

Our engineers are trying to figure out the root cause of the issue and thereby mitigate it.
Posted Oct 18, 2021 - 17:09 BST
This incident affected: SEGfL Connectivity.