Google Captch Issues
Incident Report for RM Internet & E-safety
Resolved
The issue has been confirmed as resolved and service has returned to normal.As such we are closing the Incident.
Posted 4 days ago. Jun 20, 2017 - 13:00 BST
Identified
We are aware that a number of customers have experienced an issue where they are presented with the Google Captcha (prove you are not a robot page). Google have made a change to their settings which is resulting in some customers being presented the Google Captcha page.

This issue is not caused by SafetyNet or the connection you have from us, this is due to Google changing their settings. This will be resolved when Google adjust their Captcha settings
Posted 29 days ago. May 26, 2017 - 14:12 BST
This incident affected: RM Connectivity.