Issue affecting RM Buzz customers
Incident Report for RM Internet & E-safety
Resolved
We have monitored the service and confirmed that there are no further issues reported related to this. As such we are closing this incident.
Posted Jun 10, 2020 - 05:33 BST
Monitoring
The issue has been identified and fixed. We will continue to monitor the service to ensure stability.
Posted Jun 09, 2020 - 13:57 BST
Investigating
We are aware of a Buzz extension issue affecting a few customers where browsing is affected. We'll be soon releasing a new version of extension to sort it out.
Posted Jun 04, 2020 - 12:43 BST
This incident affected: Web Filtering (SafetyNet Plus).