Update - We are continuing to monitor the performance of the service and have seen no degraded performance in the past 48 hours.
We are still diagnosing the root cause of the issue with the vendor and will share further details when we know more.

Mar 26, 2024 - 16:21 GMT
Update - There was a small disruption to the service for some customers between 13:00pm and 13:45pm today, otherwise the service has been stable. We are implementing emergency changes as suggested by the vendor this evening to stabilize further and will continue to monitor the service performance.
Mar 19, 2024 - 16:48 GMT
Update - We are continuing the monitor performance of the service today, alongside working with the vendor to understand the root cause of the issues experienced last week.

We will provide further updates once we know more.

Mar 18, 2024 - 14:57 GMT
Update - Over the last 24 hours we have been investigating and responding to a significant incident across our broadband estate.

This has impacted on a number of our customers and manifested as degraded or intermittent internet performance.

We are fully engaged with our industry partners in the investigation and resolution of this issue and have taken advice on mitigations.

Following implementation of some of these mitigations today we have seen an improvement in performance and will continue to implement further mitigations over the weekend as advised by our partners .

We will continue to update our systems status page and will send out further communication on Monday as to the status of the service.

We recognise the criticality of secure, reliable internet access for our customers and continue to take the steps necessary to deliver this.

Mar 15, 2024 - 17:09 GMT
Monitoring - After extensive troubleshooting with the vendor, we have applied some configuration changes to mitigate the impact of this incident - the service is currently stable and performing as expected.

We will continue to monitor this service closely over the coming 24 hours and apply any other recommended updates as advised by the vendor.

Mar 15, 2024 - 14:33 GMT
Investigating - We are aware of further performance issues this morning for a small subset of RM Connectivity Customers.

We are currently investigating the root cause with the vendor and will provide further updates once we know more.

Mar 15, 2024 - 11:42 GMT
Monitoring - The service is currently stable and we will continue to monitor the performance over the next 24 hours to identify root cause of the issue.
Mar 14, 2024 - 16:00 GMT
Update - We are continuing to investigate the cause of this issue and are putting in place mitigations to prevent further impact.

We will provide further updates once we know more.

Mar 14, 2024 - 14:01 GMT
Investigating - We are aware of some periodic performance issues for a small subset of RM Connectivity Customers.

We are currently investigating the root cause and will provide further updates once we know more.

Mar 14, 2024 - 11:22 GMT
RM Connectivity ? Operational
SWGfL Connectivity Operational
Bath & N.E. Somerset Operational
Bournemouth Operational
Bristol Operational
Cornwall Operational
Devon Operational
Dorset Operational
Gloucestershire Operational
N. Somerset Operational
Plymouth Operational
Poole Operational
Somerset Operational
South Gloucestershire Operational
Swindon Operational
Torbay Operational
Wiltshire Operational
SEGfL Connectivity Operational
DNS Operational
Email Operational
SMTP Store & Forward Operational
SSL Connect ? Operational
Web Filtering Operational
SafetyNet Plus Operational
SafetyNet Plus Transparent Module Operational
Web Hosting Operational
Voice Services Operational
Hosted Voice Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
RM SafetyNet - Planned Maintenance Apr 21, 2024 00:00-06:30 BST
On April 21st 00:00 - 06:30, we will be performing planned maintenance work on RM SafetyNet. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Posted on Apr 17, 2024 - 09:13 BST
RM SafetyNet Planned Maintanence Apr 21, 2024 00:00-06:30 BST
On Sunday April 21th, 2024, we will be performing planned maintenance work on RM SafetyNet service. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Posted on Apr 19, 2024 - 18:06 BST
RM SafetyNet Planned Maintanence Apr 22, 2024 00:00-06:30 BST
On Monday April 22nd, 2024, we will be performing planned maintenance work on RM SafetyNet service. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Posted on Apr 19, 2024 - 18:11 BST
RM SafetyNet Planned Maintanence Apr 23, 2024 00:00-06:30 BST
On Tuesday April 23rd, 2024, we will be performing planned maintenance work on RM SafetyNet service. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Posted on Apr 19, 2024 - 18:11 BST
RM SafetyNet - Planned Maintenance Apr 23, 2024 00:00-06:30 BST
On April 23rd 00:00 - 06:30, we will be performing planned maintenance work on RM SafetyNet. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Posted on Apr 17, 2024 - 09:13 BST
RM SafetyNet - Planned Maintenance Apr 25, 2024 19:00-23:59 BST
On April 25th 19:00 - 23:59, we will be performing planned maintenance work on RM SafetyNet. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Posted on Apr 16, 2024 - 10:48 BST
RM SafetyNet Planned Maintanence Apr 26, 2024 02:00-06:00 BST
On Friday April 26th, 2024, we will be performing planned maintenance work on RM SafetyNet service. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Posted on Apr 19, 2024 - 13:17 BST
DNS - Planned Maintenance Apr 28, 2024 19:00-23:59 BST
We will be performing maintenance on our DNS infrastructure on 28th April 2024 from 19:00 to 23:59 BST. We are not anticipating any downtime during this maintenance. This maintenance is required to keep our systems secure and up-to-date.
Posted on Apr 16, 2024 - 10:37 BST
DNS - Planned Maintenance Apr 30, 2024 00:00-06:30 BST
We will be performing maintenance on our DNS infrastructure on 30th April 2024 from 00:00 to 06:30 BST. We are not anticipating any downtime during this maintenance. This maintenance is required to keep our systems secure and up-to-date.
Posted on Apr 16, 2024 - 10:49 BST
Past Incidents
Apr 20, 2024

No incidents reported today.

Apr 19, 2024
Resolved - We have monitored the service and confirmed that there has been no further performance degradation. Our telecommunication partner have confirmed the issue has been resolved within their network.
Apr 19, 10:06 BST
Monitoring - Our Telecommunication partner have confirmed that they have identified the root cause and the issue has been resolved. It appears that the service is now stable, and we will continue the monitoring.
Apr 18, 14:22 BST
Investigating - We are aware of an internet browsing issue affecting a small number of customers using FTTP connections. We are coordinating with our Telecommunication partner to fix the issue.
Apr 18, 13:07 BST
Completed - The scheduled maintenance has been completed.
Apr 19, 06:30 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 19, 00:00 BST
Scheduled - On April 19th 00:00 - 06:30, we will be performing planned maintenance work on RM SafetyNet. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Apr 17, 09:12 BST
Apr 18, 2024
Apr 17, 2024
Completed - The scheduled maintenance has been completed.
Apr 17, 06:30 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 17, 00:00 BST
Scheduled - On 17th April, we will be performing planned maintenance work on the RM Safetynet Infrastructure. We do not anticipate any impact to the performance, resilience or availability of RM SafetyNet filtering during this window.
Apr 7, 11:17 BST
Completed - The scheduled maintenance has been completed.
Apr 17, 06:00 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 17, 01:00 BST
Scheduled - On Wednesday April 17th, 2024, we will be performing planned maintenance work on RM SafetyNet service. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Apr 15, 13:22 BST
Apr 16, 2024
Completed - The scheduled maintenance has been completed.
Apr 16, 06:00 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 16, 01:00 BST
Scheduled - On Tuesday April 16th 01:00 - 06:00, we will be performing planned maintenance work on RM SafetyNet service. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Apr 15, 13:14 BST
Apr 15, 2024
Completed - The scheduled maintenance has been completed.
Apr 15, 06:30 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 15, 00:00 BST
Scheduled - On 15th April, we will be performing planned maintenance work on the RM Safetynet Infrastructure. We do not anticipate any impact to the performance, resilience or availability of RM SafetyNet filtering during this window.
Apr 7, 11:16 BST
Apr 14, 2024

No incidents reported.

Apr 13, 2024
Completed - The scheduled maintenance has been completed.
Apr 13, 06:30 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 13, 00:00 BST
Scheduled - On 13th April , we will be performing planned maintenance work on the RM SafetyNet Infrastructure. We do not anticipate any impact to the performance, resilience or availability of RM SafetyNet filtering during this window.
Apr 7, 11:15 BST
Apr 12, 2024
Completed - The scheduled maintenance has been completed.
Apr 12, 20:00 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 2, 08:00 BST
Scheduled - As part of the continuous improvement of our connectivity service, we will be performing some upgrades to our core network over the Easter period to increase security, capacity and resilience. A brief period of downtime may occur within the maintenance window, but due to the resilient nature of the network any impact is expected to be minimal.
Mar 21, 09:23 GMT
Apr 11, 2024
Completed - The scheduled maintenance has been completed.
Apr 11, 06:00 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 11, 01:00 BST
Scheduled - On Thursday April 11th 01:00 - 06:00, we will be performing planned maintenance work on RM SafetyNet service. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Apr 10, 18:53 BST
Apr 10, 2024

No incidents reported.

Apr 9, 2024
Completed - The scheduled maintenance has been completed.
Apr 9, 06:00 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 9, 01:00 BST
Scheduled - On Tuesday April 9th 01:00 - 06:00, we will be performing planned maintenance work on RM SafetyNet service. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Apr 5, 08:41 BST
Apr 8, 2024
Completed - The scheduled maintenance has been completed.
Apr 8, 06:30 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 8, 00:05 BST
Scheduled - We will be performing maintenance on our DNS and Email relay servers on Monday 8th April 2024 from 00:05 to 06:30 BST. We are not anticipating any downtime for the service during this work. This maintenance is required to keep our systems secure and up-to-date.
Mar 20, 08:55 GMT
Completed - The scheduled maintenance has been completed.
Apr 8, 06:00 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 8, 01:00 BST
Scheduled - On Monday April 8th 01:00 - 06:00, we will be performing planned maintenance work on RM SafetyNet service. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Apr 5, 08:41 BST
Apr 7, 2024
Completed - The scheduled maintenance has been completed.
Apr 7, 06:00 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 7, 01:00 BST
Scheduled - On Sunday April 7th 01:00 - 06:00, we will be performing planned maintenance work on RM SafetyNet service. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Apr 5, 08:40 BST
Apr 6, 2024
Completed - The scheduled maintenance has been completed.
Apr 6, 06:00 BST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 6, 01:00 BST
Scheduled - On Saturday April 6th 01:00 - 06:00, we will be performing planned maintenance work on RM SafetyNet service. A brief period of downtime to the services may occur within the maintenance window, but due to the resilient nature of the infrastructure, any impact is expected to be minimal.
Apr 2, 12:07 BST