Intermittent issues with self service portals
Incident Report for RM Internet & E-safety
Resolved
The issue affecting our self-service portals is now resolved all portals are working as expected. This incident will now be closed.
Posted 7 months ago. Jan 05, 2018 - 07:51 GMT
Identified
We are aware of an intermittent issue customers are experiencing using our self-service portals on RM.com and SWGfL ESI. We are working to resolve this as a priority. The service desk can still be contacted by phone, email or web chat.
Posted 7 months ago. Jan 04, 2018 - 16:03 GMT
This incident affected: RM Connectivity.