Connectivity outage affecting TalkTalk customers
Incident Report for RM Internet & E-safety
Resolved
We have monitored the service and confirmed that all the affected connections are stable now. As such we are closing this incident
Posted Jul 22, 2021 - 15:51 BST
Monitoring
Connectivity has been restored to all the affected sites.Telco engineer is at site for further investigation .Further updates will be provided in due course.
Posted Jul 19, 2021 - 15:27 BST
Investigating
We are aware of an outage affecting FTTC, EoFTTC, and Leased Line customers. Our Telco supplier is aware of the issue and is investigating as a matter of urgency. Further updates will be provided in due course.
Posted Jul 19, 2021 - 13:17 BST
This incident affected: RM Connectivity and SWGfL Connectivity (Devon, Dorset, Poole).