Connectivity Issues for Talk Talk customers
Incident Report for RM Internet & E-safety
Resolved
We have monitored the affected customers overnight and the service is stable now. Hence we are closing the incident
Posted May 18, 2017 - 09:05 BST
Update
TalkTalk Engineers have restored connectivity of the affected customers. We are monitoring the service to ensure stability.
Posted May 17, 2017 - 12:19 BST
Update
19 of our customers still have connectivity issues due to a fibre damage. TalkTalk have advised that work to restore service is ongoing but due to the extent of the damage this is taking longer than expected. Our Engineers continue to liaise with the Service provider for resolution.
Posted May 17, 2017 - 08:53 BST
Identified
We are still seeing Connectivity issues to a subset of our customers and our Engineers are liaising with the Service provider to restore the services as priority.
Posted May 17, 2017 - 07:35 BST
Investigating
We are aware of an issue that has caused a brief internet outage for customers on Talk Talk connections. The issue is caused by emergency planned works. We are coordinating with the provider on this.
Posted May 17, 2017 - 03:43 BST
This incident affected: RM Connectivity.