Service Desk Telephone issue
Incident Report for RM Internet & E-safety
Resolved
The issue affecting our telephone system is now resolved. The Service Desk phone lines are working as expected.
Posted Jul 18, 2017 - 14:35 BST
Investigating
We are having some intermittent issues with our telephone lines at the moment. We are working to fix this as a top priority. If you are unable to reach us by phone the Service desk can be contacted on web chat through rm.com or through the SafetyNet admin interface or at ihgsupport@rm.com
Posted Jul 18, 2017 - 08:23 BST
This incident affected: RM Connectivity.