Delayed email delivery to Office 365 Domains
Incident Report for RM Internet & E-safety
Resolved
We have monitored the services and no issues identified. As such we are closing this incident.
Posted Apr 04, 2017 - 09:22 BST
Monitoring
The Delay in Email delivery to Office 365 has been resolved. We will monitor the server for couple of days before closing this incident.
Posted Mar 31, 2017 - 14:59 BST
Investigating
We are currently experiencing issues with delayed email delivery to domains hosted on the Microsoft Office 365 platform. Our engineers are checking with Microsoft to resolve this issue.
Posted Mar 27, 2017 - 16:08 BST
This incident affected: SWGfL Connectivity (Bath & N.E. Somerset, Bournemouth, Cornwall, Devon, Dorset, Gloucestershire, N. Somerset, Plymouth, Poole, Somerset, South Gloucestershire, Swindon, Torbay, Wiltshire).